import Foundation
let pattern = #"(-I.*?(?="))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1334 execve("/home/y/bin64/ccache", ["/home/y/bin64/ccache", "/usr/bin/g++", "-fPIC", "-g", "-O2", "-Wall", "-pipe", "-MD", "-MP", "-D_REENTRANT", "-DLINUX", "-D_GNU_SOURCE", "-D_THREAD_SAFE", "-DUSE_STD_YUTSTRING", "-DNO_FACTORY", "-I/home/lniu/component/.build/include", "-I../include/", "-I../include/sample/", "-I/home/include64", "-I/home/include", "-I/home/lniu/sample", "-I/home/lniu/sample/../libraries", "-o", "x86_64-linux-gcc/sample"], [/* 63 vars */]) = 0"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)