const regex = /(-I.*?(?="))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(-I.*?(?="))', 'g')
const str = `1334 execve("/home/y/bin64/ccache", ["/home/y/bin64/ccache", "/usr/bin/g++", "-fPIC", "-g", "-O2", "-Wall", "-pipe", "-MD", "-MP", "-D_REENTRANT", "-DLINUX", "-D_GNU_SOURCE", "-D_THREAD_SAFE", "-DUSE_STD_YUTSTRING", "-DNO_FACTORY", "-I/home/lniu/component/.build/include", "-I../include/", "-I../include/sample/", "-I/home/include64", "-I/home/include", "-I/home/lniu/sample", "-I/home/lniu/sample/../libraries", "-o", "x86_64-linux-gcc/sample"], [/* 63 vars */]) = 0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}