$re = '/(-I.*?(?="))/';
$str = '1334 execve("/home/y/bin64/ccache", ["/home/y/bin64/ccache", "/usr/bin/g++", "-fPIC", "-g", "-O2", "-Wall", "-pipe", "-MD", "-MP", "-D_REENTRANT", "-DLINUX", "-D_GNU_SOURCE", "-D_THREAD_SAFE", "-DUSE_STD_YUTSTRING", "-DNO_FACTORY", "-I/home/lniu/component/.build/include", "-I../include/", "-I../include/sample/", "-I/home/include64", "-I/home/include", "-I/home/lniu/sample", "-I/home/lniu/sample/../libraries", "-o", "x86_64-linux-gcc/sample"], [/* 63 vars */]) = 0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);