import re
regex = re.compile(r"(-I.*?(?=\"))")
test_str = "1334 execve(\"/home/y/bin64/ccache\", [\"/home/y/bin64/ccache\", \"/usr/bin/g++\", \"-fPIC\", \"-g\", \"-O2\", \"-Wall\", \"-pipe\", \"-MD\", \"-MP\", \"-D_REENTRANT\", \"-DLINUX\", \"-D_GNU_SOURCE\", \"-D_THREAD_SAFE\", \"-DUSE_STD_YUTSTRING\", \"-DNO_FACTORY\", \"-I/home/lniu/component/.build/include\", \"-I../include/\", \"-I../include/sample/\", \"-I/home/include64\", \"-I/home/include\", \"-I/home/lniu/sample\", \"-I/home/lniu/sample/../libraries\", \"-o\", \"x86_64-linux-gcc/sample\"], [/* 63 vars */]) = 0"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")