using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*presence-device-id=(.*?)[;\n\r$].*";
string input = @"uc-client=mobile;device-type=ios;presence-device-id=MI_6B45EA1F24BE48B5B515D6";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}