const regex = /.*presence-device-id=(.*?)[;\n\r$].*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*presence-device-id=(.*?)[;\\n\\r$].*', '')
const str = `uc-client=mobile;device-type=ios;presence-device-id=MI_6B45EA1F24BE48B5B515D6`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}