re = /.*presence-device-id=(.*?)[;\n\r$].*/
str = 'uc-client=mobile;device-type=ios;presence-device-id=MI_6B45EA1F24BE48B5B515D6'
# Print the match result
str.match(re) do |match|
puts match.to_s
end