import Foundation
let pattern = #".*presence-device-id=(.*?)[;\n\r$].*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"uc-client=mobile;device-type=ios;presence-device-id=MI_6B45EA1F24BE48B5B515D6"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}