use strict;
my $str = 'uc-client=mobile;device-type=ios;presence-device-id=MI_6B45EA1F24BE48B5B515D6';
my $regex = qr/.*presence-device-id=(.*?)[;\n\r$].*/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}