$re = '/.*presence-device-id=(.*?)[;\n\r$].*/';
$str = 'uc-client=mobile;device-type=ios;presence-device-id=MI_6B45EA1F24BE48B5B515D6';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);