#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d{1,2}\-\d{1,2}\-\d{4}"
Local $sString = "srv-test-01.test.ru(192.168.100.100) VMware: Free space on datastore 02-12-2012 (percentage)" & @CRLF & _
"srv-test-01.test.ru(192.168.100.102) VMware: Free space on datastore 18-42-2402 (percentage)" & @CRLF & _
"srv-test-01.test.ru(192.168.100.103) VMware: Free space on datastore 49-12-2001 (percentage)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")