$re = '/\d{1,2}\-\d{1,2}\-\d{4}/m';
$str = 'srv-test-01.test.ru(192.168.100.100) VMware: Free space on datastore 02-12-2012 (percentage)
srv-test-01.test.ru(192.168.100.102) VMware: Free space on datastore 18-42-2402 (percentage)
srv-test-01.test.ru(192.168.100.103) VMware: Free space on datastore 49-12-2001 (percentage)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);