import Foundation
let pattern = #"\d{1,2}\-\d{1,2}\-\d{4}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
srv-test-01.test.ru(192.168.100.100) VMware: Free space on datastore 02-12-2012 (percentage)
srv-test-01.test.ru(192.168.100.102) VMware: Free space on datastore 18-42-2402 (percentage)
srv-test-01.test.ru(192.168.100.103) VMware: Free space on datastore 49-12-2001 (percentage)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)