package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{1,2}\-\d{1,2}\-\d{4}`)
var str = `srv-test-01.test.ru(192.168.100.100) VMware: Free space on datastore 02-12-2012 (percentage)
srv-test-01.test.ru(192.168.100.102) VMware: Free space on datastore 18-42-2402 (percentage)
srv-test-01.test.ru(192.168.100.103) VMware: Free space on datastore 49-12-2001 (percentage)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}