import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?://(www\\.|m\\.)?(youtube\\.com|youtu\\.be|youtube-nocookie\\.com)/(((?!([\\\"'<])).)*)";
final String string = "https://youtube.com/lorem\n"
+ "https://youtu.be/ipsum\n"
+ "https://youtube-nocookie.com/dolor\n"
+ "https://www.youtube.com/sit\n"
+ "https://www.youtu.be/amet\n"
+ "https://www.youtube-nocookie.com/consectetur\n"
+ "https://m.youtube.com/adipiscing\n"
+ "https://m.youtu.be/elit\n"
+ "https://m.youtube-nocookie.com/sed\n"
+ "https://not-youtube.com/do\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}