import Foundation
let pattern = #"https?://(www\.|m\.)?(youtube\.com|youtu\.be|youtube-nocookie\.com)/(((?!([\"'<])).)*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
https://youtube.com/lorem
https://youtu.be/ipsum
https://youtube-nocookie.com/dolor
https://www.youtube.com/sit
https://www.youtu.be/amet
https://www.youtube-nocookie.com/consectetur
https://m.youtube.com/adipiscing
https://m.youtu.be/elit
https://m.youtube-nocookie.com/sed
https://not-youtube.com/do
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)