use strict;
my $str = 'https://youtube.com/lorem
https://youtu.be/ipsum
https://youtube-nocookie.com/dolor
https://www.youtube.com/sit
https://www.youtu.be/amet
https://www.youtube-nocookie.com/consectetur
https://m.youtube.com/adipiscing
https://m.youtu.be/elit
https://m.youtube-nocookie.com/sed
https://not-youtube.com/do
';
my $regex = qr/https?://(www\.|m\.)?(youtube\.com|youtu\.be|youtube-nocookie\.com)/(((?!([\"'<])).)*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}