re = /https?:\/\/(www\.|m\.)?(youtube\.com|youtu\.be|youtube-nocookie\.com)\/(((?!([\"'<])).)*)/
str = 'https://youtube.com/lorem
https://youtu.be/ipsum
https://youtube-nocookie.com/dolor
https://www.youtube.com/sit
https://www.youtu.be/amet
https://www.youtube-nocookie.com/consectetur
https://m.youtube.com/adipiscing
https://m.youtu.be/elit
https://m.youtube-nocookie.com/sed
https://not-youtube.com/do
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end