const regex = new RegExp('https?://(www\\.|m\\.)?(youtube\\.com|youtu\\.be|youtube-nocookie\\.com)/(((?!([\\"\\'<])).)*)', 'g')
const str = `https://youtube.com/lorem
https://youtu.be/ipsum
https://youtube-nocookie.com/dolor
https://www.youtube.com/sit
https://www.youtu.be/amet
https://www.youtube-nocookie.com/consectetur
https://m.youtube.com/adipiscing
https://m.youtu.be/elit
https://m.youtube-nocookie.com/sed
https://not-youtube.com/do
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}