# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"https?://(www\.|m\.)?(youtube\.com|youtu\.be|youtube-nocookie\.com)/(((?!([\"'<])).)*)"
test_str = ("https://youtube.com/lorem\n"
"https://youtu.be/ipsum\n"
"https://youtube-nocookie.com/dolor\n"
"https://www.youtube.com/sit\n"
"https://www.youtu.be/amet\n"
"https://www.youtube-nocookie.com/consectetur\n"
"https://m.youtube.com/adipiscing\n"
"https://m.youtu.be/elit\n"
"https://m.youtube-nocookie.com/sed\n"
"https://not-youtube.com/do\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.