const regex = /(?<=h.llo )[A-Za-z]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=h.llo )[A-Za-z]+', 'gm')
const str = `hello everyone, hullo anything`;
const subst = `world`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);