use strict;
my $str = 'hello everyone, hullo anything';
my $regex = qr/(?<=h.llo )[A-Za-z]+/mp;
my $subst = 'world';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";