$re = '/(?<=h.llo )[A-Za-z]+/m';
$str = 'hello everyone, hullo anything';
$subst = "world";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;