re = /(?<=h.llo )[A-Za-z]+/m
str = 'hello everyone, hullo anything'
subst = 'world'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result