#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\bfoo\b(?!(?:(?!<\/?a\b[^>]*>).)*?<\/a>)"
Local $sString = "<a>foo</a>foo"
Local $sSubst = "<a class="highlight">foo</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)