re = /\bfoo\b(?!(?:(?!<\/?a\b[^>]*>).)*?<\/a>)/m
str = '<a>foo</a>foo'
subst = '<a class="highlight">foo</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result