import Foundation
let pattern = #"\bfoo\b(?!(?:(?!<\/?a\b[^>]*>).)*?<\/a>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<a>foo</a>foo"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a class="highlight">foo</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)