$re = '/\bfoo\b(?!(?:(?!<\/?a\b[^>]*>).)*?<\/a>)/m';
$str = '<a>foo</a>foo';
$subst = "<a class=\"highlight\">foo</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;