import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bfoo\\b(?!(?:(?!<\\/?a\\b[^>]*>).)*?<\\/a>)";
final String string = "<a>foo</a>foo";
final String subst = "<a class=\"highlight\">foo</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}