use strict;
my $str = '<a>foo</a>foo';
my $regex = qr/\bfoo\b(?!(?:(?!<\/?a\b[^>]*>).)*?<\/a>)/mp;
my $subst = '<a class="highlight">foo</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";