#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^|[[:punct:]]| )les(?:[[:punct:]]| |$)"
Local $sString = "les < I need match" & @CRLF & _
"lesík < NO" & @CRLF & _
"za-les-nit < I need match" & @CRLF & _
"les'ns < I need match" & @CRLF & _
"odlesnit < NO" & @CRLF & _
"useless < NO" & @CRLF & _
"doles < NO" & @CRLF & _
"kolem je les, který ... < I need match"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")