re = /(?:^|[[:punct:]]| )les(?:[[:punct:]]| |$)/m
str = 'les < I need match
lesík < NO
za-les-nit < I need match
les\'ns < I need match
odlesnit < NO
useless < NO
doles < NO
kolem je les, který ... < I need match'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end