import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|[[:punct:]]| )les(?:[[:punct:]]| |$)";
final String string = "les < I need match\n"
+ "lesík < NO\n"
+ "za-les-nit < I need match\n"
+ "les'ns < I need match\n"
+ "odlesnit < NO\n"
+ "useless < NO\n"
+ "doles < NO\n"
+ "kolem je les, který ... < I need match";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}