package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^|[[:punct:]]| )les(?:[[:punct:]]| |$)`)
var str = `les < I need match
lesík < NO
za-les-nit < I need match
les'ns < I need match
odlesnit < NO
useless < NO
doles < NO
kolem je les, který ... < I need match`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}