use strict;
my $str = 'les < I need match
lesík < NO
za-les-nit < I need match
les\'ns < I need match
odlesnit < NO
useless < NO
doles < NO
kolem je les, který ... < I need match';
my $regex = qr`(?:^|[[:punct:]]| )les(?:[[:punct:]]| |$)`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}