$re = '`(?:^|[[:punct:]]| )les(?:[[:punct:]]| |$)`m';
$str = 'les < I need match
lesík < NO
za-les-nit < I need match
les\'ns < I need match
odlesnit < NO
useless < NO
doles < NO
kolem je les, který ... < I need match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);