#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*?\.?(\w+)(?=\t)"
Local $sString = "test.output0 testx.testj.output1 output3 testds.no.output2 "
Local $sSubst = "$1\t"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)