$re = '/.*?\.?(\w+)(?=\t)/m';
$str = 'test.output0 testx.testj.output1 output3 testds.no.output2 ';
$subst = "$1\t";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;