import Foundation
let pattern = #".*?\.?(\w+)(?=\t)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"test.output0 testx.testj.output1 output3 testds.no.output2 "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\t"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)