const regex = /.*?\.?(\w+)(?=\t)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?\\.?(\\w+)(?=\\t)', 'gm')
const str = `test.output0 testx.testj.output1 output3 testds.no.output2 `;
const subst = `$1\t`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);