re = /.*?\.?(\w+)(?=\t)/m
str = 'test.output0 testx.testj.output1 output3 testds.no.output2 '
subst = '$1\\t'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result