#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z]+(-?[a-z]){0,63}-?[a-z]+$"
Local $sString = "my-valid-self-signed-cert" & @CRLF & _
"myvalidcert" & @CRLF & _
"" & @CRLF & _
"myInvalidCert" & @CRLF & _
"-my-invalid-self-signed-cert" & @CRLF & _
"my-invalid-self-signed-cert-" & @CRLF & _
"my-invalid--self-singed-cert" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")