package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z]+(-?[a-z]){0,63}-?[a-z]+$`)
var str = `my-valid-self-signed-cert
myvalidcert
myInvalidCert
-my-invalid-self-signed-cert
my-invalid-self-signed-cert-
my-invalid--self-singed-cert
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}