$re = '/^[a-z]+(-?[a-z]){0,63}-?[a-z]+$/m';
$str = 'my-valid-self-signed-cert
myvalidcert
myInvalidCert
-my-invalid-self-signed-cert
my-invalid-self-signed-cert-
my-invalid--self-singed-cert
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);