re = /^[a-z]+(-?[a-z]){0,63}-?[a-z]+$/m
str = 'my-valid-self-signed-cert
myvalidcert
myInvalidCert
-my-invalid-self-signed-cert
my-invalid-self-signed-cert-
my-invalid--self-singed-cert
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end