const regex = /^[a-z]+(-?[a-z]){0,63}-?[a-z]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z]+(-?[a-z]){0,63}-?[a-z]+$', 'gm')
const str = `my-valid-self-signed-cert
myvalidcert
myInvalidCert
-my-invalid-self-signed-cert
my-invalid-self-signed-cert-
my-invalid--self-singed-cert
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}