using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[Vidible.*?vids=\""(.*?)\"".*?\]";
string input = @"Plugin test.\r\n\r\n[Vidible pid=""540733fae4b061fe2c0e6532"" bcid=""538612f0e4b00fbb8e898655"" vids=""5407208be4b0e541a65ce855,53e1cd2ce4b07ee7365f29d1,53fc8bcde4b0bbef08f3bfbd""]\r\n\r\nMore text.x[Vidible pid=""540733fae4b061fe2c0e6532"" bcid=""538612f0e4b00fbb8e898655"" vids=""5407208be4b0e541a65ce855,53e1cd2ce4b07ee7365f29d1,53fc8bcde4b0bbef08f3bfbd""]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}