import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[Vidible.*?vids=\\\"(.*?)\\\".*?\\]";
final String string = "Plugin test.\\r\\n\\r\\n[Vidible pid=\"540733fae4b061fe2c0e6532\" bcid=\"538612f0e4b00fbb8e898655\" vids=\"5407208be4b0e541a65ce855,53e1cd2ce4b07ee7365f29d1,53fc8bcde4b0bbef08f3bfbd\"]\\r\\n\\r\\nMore text.x[Vidible pid=\"540733fae4b061fe2c0e6532\" bcid=\"538612f0e4b00fbb8e898655\" vids=\"5407208be4b0e541a65ce855,53e1cd2ce4b07ee7365f29d1,53fc8bcde4b0bbef08f3bfbd\"]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}