import Foundation
let pattern = #"\[Vidible.*?vids=\"(.*?)\".*?\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Plugin test.\r\n\r\n[Vidible pid="540733fae4b061fe2c0e6532" bcid="538612f0e4b00fbb8e898655" vids="5407208be4b0e541a65ce855,53e1cd2ce4b07ee7365f29d1,53fc8bcde4b0bbef08f3bfbd"]\r\n\r\nMore text.x[Vidible pid="540733fae4b061fe2c0e6532" bcid="538612f0e4b00fbb8e898655" vids="5407208be4b0e541a65ce855,53e1cd2ce4b07ee7365f29d1,53fc8bcde4b0bbef08f3bfbd"]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)