import re
regex = re.compile(r"\[Vidible.*?vids=\"(.*?)\".*?\]")
test_str = "Plugin test.\\r\\n\\r\\n[Vidible pid=\"540733fae4b061fe2c0e6532\" bcid=\"538612f0e4b00fbb8e898655\" vids=\"5407208be4b0e541a65ce855,53e1cd2ce4b07ee7365f29d1,53fc8bcde4b0bbef08f3bfbd\"]\\r\\n\\r\\nMore text.x[Vidible pid=\"540733fae4b061fe2c0e6532\" bcid=\"538612f0e4b00fbb8e898655\" vids=\"5407208be4b0e541a65ce855,53e1cd2ce4b07ee7365f29d1,53fc8bcde4b0bbef08f3bfbd\"]"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")